How to Compile?

How to Run?

WPS Namelist

WPS Updates

Known Problems and Fixes

 

 

 

WRF Preprocessing System Version 3.9.0.1: Known Problems and Fixes

Problem when Compiling WPSV3.9.0.1 with PGI Compilers

When compiling WPSV3.9.0.1 with PGI compilers, you will likely receive these errors:

PGF90-S-0155-Intrinsic not supported in initialization: scale (mkieee.f: 35)
PGF90-S-0155-Intrinsic not supported in initialization: scale (mkieee.f: 36)

PGF90-S-0155-Intrinsic not supported in initialization: scale (rdieee.f: 35)
PGF90-S-0155-Intrinsic not supported in initialization: scale (rdieee.f: 36)

To correct this, you will need 2 files, packaged here. Place this tar file in your WPS/ungrib/src/ngl/g2/ directory, unpack the tar file, and then go back to WPS/ and go through the configure/compile process.



Problem when Compiling with Older Gfortran Compiler

If compiling the WPS code with older versions of gfortran (we have yet to determine exactly how old), you likely will receive errrors such as:

read_namelist.f90:72.25:

add_lvls, new_plvl, interp_type
1
Error: NAMELIST attribute conflicts with ALLOCATABLE attribute in 'new_plvl' at (1)
read_namelist.f90:238.20:

read(10,NML=ungrib,END=100)

1 Error: Symbol 'ungrib' at (1) must be a NAMELIST group name

One solution would be to upgrade to a newer version of gfortran. Another simple, quick solution would be to go into the read_namelist.F file, found in ungrib/src/, and go to line 56. Change it to:

real, dimension(250) :: new_plvl

Then delete line 74:

allocate(new_plvl(size(new_plvl_in)))

and delete line 297:

deallocate(new_plvl)

Save the read_namelist.F file, then recompile again.

 

 


 

 

 

 

 



 
Home -- Model System -- User Support -- Doc / Pub -- Links -- Download -- WRF Real-time Forecast